Problem with downloading statements.
Incident Report for Woodpecker.co
Resolved
There should be no more problems with downloading your statement now.
Posted over 1 year ago. Jul 15, 2016 - 16:39 CEST
Identified
You might experience problem while trying to download statement from our page. We are actively working to fix this issue.
Posted over 1 year ago. Jul 15, 2016 - 12:23 CEST